2 tinyfpgas, 2 usb cables, 2 computers -- not working


#1

I’m pretty stumped here.

I purchased a TinyFPGA BX a few weeks ago.
I followed the simple instructions to install apio, tinyfpga, etc on Windows 10
https://tinyfpga.com/bx/guide.html

When I executed 'tinyprog --update-bootloader`, it printed:
No port was specified and no active bootloaders found.
Activate bootloader by pressing the reset button.

When I executed ‘apio system --lsserial’, it printed:
Number of Serial devices found: 0

Same results with every usb port on my PC. I tried a different USB cable, same result. I then tried it on 2019 macbook pro. Same result with both usb cables.
I figured the tinyfpga bx was defective so I ordered another one.

The second one arrived tonight and has the same issue, on both computers, with two different usb cables.

Certainly the odds must be tiny that I received two defective units in a row.

On both boards, when plugged into usb, I see one solid light and one flashing light, as expected.


#2

So I found a third usb cable, and it worked!

Issue resolved =)


#3

Similar thing happened to me. It turned out my usb cable was a power only cable. Power only cables can useful if you have an image loaded on the TinyFPGA.