BX can't connect to vmware workstation


#1

Hi,

I’m running VMWare Workstation on Windows 10, with a Xubuntu 18.04 VM. As far as I can tell, all software packages are as up-to-date as possible. When I connect my BX to my windows PC, it shows up as COM3. However, when I try to attach it to a virtual machine, I get the following error:

“The connection for the USB device ‘OpenMoko USB Serial Device’ was unsuccessful: Driver error”.

I use lots of development boards successfully via VMWare (ST, TI, ESP, other lattice boards, Xilinx, Altera, etc), so I’m thinking this is an issue with the BX bootloader. Is there perhaps some delay or timeout period in the bootloader where it tries to talk to a USB host stack which could be increased? I suspect that while the device is transitioning between the Windows stack and the VMWare stack, it resets itself.


#2

Not that it’s directly comparable, but I am using VMware fusion for my TinyFPGA development, and it works without issues. In my case though the host OS is MacOS and the guest is Ubuntu 16.04. I tried Ubuntu 18.04, and it mainly worked, but I couldn’t get the simulation/testbench software to work due to library conflicts.

In any case, when I plug TinyFPGA in to the Mac, I get a dialogue asking me whether I want to connect it to the host machine or the VM. Do you get the same dialog from VMWare workstation in windows?

On the Mac I’m able to default that dialog so that the board always connects to the VM, which I’ve done now. It seemed to work okay before that, but I wonder in your case, if you haven’t done this already, whether it might reduce the potential for timeouts?

Also, it seems like some people might be having USB issues specific to Windows 10 with VMWare, which may be resolved by uninstalling and re-installing … https://communities.vmware.com/thread/516795. It seems a little drastic, but may be an option.


#3

Thanks for your input. I do have VMWare Fusion also on a mac, but I haven’t tried this yet.

Unfortunately I have been bitten by things similar to this problem before, see for example: https://github.com/espressif/esptool/issues/323

It seems to come from timing issues between various drivers. I’ll try reinstalling when I get some more lengthy free time, but that post is from 2015 so I’m not sure if things are still that way.


#4

I’ve been playing with this some more, and I get another error which I had overlooked before; windows reports “USB device not recognised” after trying to connect the device to VMWare. I’ve also uninstalled and reinstalled VMWare as per that thread (incl. uninstalling my USB root hub).


#5

I’ve also just tried every USB dev board near my desk (8 of them so far) and all of them work fine with the virtual machine. So I really think it is the BX bootloader.


#6

I’ve also just tried copying the exact virtual machine to my mac, and it seems to work fine. So it is either Windows 10 or VMWare related.