Can't upload to the board(FIXED!)


#1

Error: No JSON object could be decoded!


#2

This is something I debugged with another user and we determined it to be an APIO bug. It appears to only affect certain installations. Can you post your operating system information?

Until this is fixed in APIO, You should still be able to program using ‘tinyprog’ directly.

pip install —upgrade tinyprog
tinyprog -p hardware.bin


#3

I’ll look through that thread.
Here is uname -a: 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


#4

What version of python?


#5

Python version is Python 2.7.15rc1


#6

I have created another user and started over and everything is now working.
I now have Morse code on the LEDs thanks for the help.


#7

Glad to hear! Very strange that a new user account solved the problem.


#8

I have something screwed up it’s my fault! Sorry about that!


#9

Whew! Thanks for the debug on your side. :joy: What was the issue? Useful in case other people run into the same problem.


#10

I think I ran something with sudo and confused it. I think it’s a rights thing, It’s all good here plus I have a windows partition if need be. Habits are hard to break and using sudo instead of logging in as root makes no difference. Standard ID10T error…lol


#11

sudo tinyprog -p hardware.bin

TinyProg CLI
------------
Using device id 1d50:6130
Only one board with active bootloader, using it.
Programming /dev/ttyACM0 with hardware.bin
Programming at addr 028000
Waking up SPI flash
135100 bytes to program
Erasing: 100%|████████████████████████████| 135k/135k [00:01<00:00, 131kB/s]
Writing: 100%|████████████████████████████| 135k/135k [00:00<00:00, 177kB/s]
Reading: 100%|████████████████████████████| 135k/135k [00:00<00:00, 430kB/s]
Success!

#12

Does apio upload work for you?


#13

GOT it! It was a rights issue with /dev/ttyACM0 for some reason. chown fixed the issue. I still have no idea how I managed that one! Everything is great now! Working in apio/atom and the CLI.


#14

I also had this problem.

I added myself to the “dialout” group and chowned myself as the owner. Atom will now upload. Btw, I would’ve thought that being a member of the “dialout” group would enable me to access the port from atom but that didn’t appear to work.