Com port does not show up on Win 10 [SOLVED]


#1

Tried plugging into hub, and also 2 different USB connections on laptop directly no sound from Windows, just power - and board has power LED and about 2 Hz pulsating LED. tinyprog 1.0.11
$ apio system --lsserial
Number of Serial devices found: 0
$ tinyprog -m
[]
$ tinyprog -l

TinyProg CLI
------------
Using device id 1d50:6130
No port was specified and no active bootloaders found.
Activate bootloader by pressing the reset button

NOW, if I press AND HOLD the Reset button, Windows shows in Device Manager:
Unknown USB Device (Device Descriptor Request Failed)

and when I let go of the Reset button, that Device Manager line under “Universal Serial Bus contolllers” goes away. At no time does any other serial port appear under Ports (COM & LPT) in Device Manager.

When I hold the Reset button down, the outermost LED goes to about 1/4 intensity.

I have 2 boards, they both show identical symptoms.

Help! All of my USB ports are USB 3.0 ports; could that be a problem?


#2

This holds the FPGA in reset, it can’t do anything while in this state.

I’ve connected the board to both USB 3 and USB 2 ports without any issues, I don’t think that is the issue.

What CPU do you have in your laptop? Intel or AMD?


#3

Intel Xeon E3 - 1200/1500 v5/6th Gen – Thinkpad P70


#4

Is there anything else I can try? I am a geek, so can go pretty deep. Or should I return them? Should I sent them to you?

A clue, I think, is that when I press and hold the reset button for about 2 seconds, Win 10’s Device Manager under Universal Serial Bus controllers shows:

Unknown USB Device (Device Descriptor Request Failed)

Otherwise, nothing is shown in that section, nor is any ‘windows sound’ made when device is plugged in (which it does when recognizing a new device usually).

This suggests to me that, when the button is pressed and held for about 2 seconds, SOMETHING is happening, because otherwise Win 10 wouldn’t do what it does.

Thanks!


#5

I’m looking into this as well…I’m trying to figure out which version of libusb you should install. If you have libusb installed, you can try the latest tinyprog beta I made for the people using MacOS. If you use that version with the —libusb command line flag you might get better results.


#6

You’ll want the tinyprog version installed in this post: Can't create serial port


#7

Good News, and Bad News. Good News: it works! with the old(er) software, too. New s/w also works.

the Bad News: I believe I have uncovered an electrical design issue with your USB implementation. It now works when I replaced the approximately 1 meter USB 2.0 certified cable with a 150-mm USB cable. Plugging that in immediately got Windows to say it was handling the driver, and all was good after that.

I suspect there is some Signal Integrity issue that needs to be handled; or maybe just asking people to use shorter USB cables. I suspect (wild guess) that there are reflections due to improper termination.

Thanks again for a super-duper board, and I know it takes a lot of effort to pull something like this off as a 1-man team. I appreciate your contribution.


#8

Interesting, I use 2-meter cables all the time and haven’t had any issues. It could be that specific cable, or a combination of that cable and computer.

Glad to hear it’s working for you though! :smile:


#9

I had the same issue with a 1m cable, and I consider this my “good” usb cable.