Dead TinyFPGA B2 [solved]


#1

Hello there, I just got my first B2, and when I try to find it with tinyfpgab, it says it can’t find any devices, and my USB stack doesn’t show any devices connected. (I’m running on OSX, when I connect the USB device, I do not get a new entry in the “USB Device Tree” from System Information) How should I debug the board to see if it is indeed dead?


#2

Have you tried connecting it to another computer or with a different OS?


#3

Yes, I tried it on my windows machine as well, with a separate USB cable. Neither computer recognizes that I have plugged in a new USB device. While it is plugged in, looking at it with my scope shows roughly what I would expect; 5v, 3.3v and 1.2v on the pins marked accordingly, the CLK pin has a 16.1MHz signal coming out (oscillating from 0 to 2.5V) and every other pin is at 3.1V. So perhaps there is just something wrong with the USB connection?


#4

Hmm, interesting. Ok, send me a private message with your order information and I’ll help you out.


#5

Alrighty! New B2 and return postage for old B2 is on its way. :smile::+1:t2:


#6

To close the loop on this, Luke sent me a new board which had the same problem, and only then did I think to test the two cables I was using on another device. It turns out they were both “power only” USB cables. Sigh. Thank you Luke, for your excellent customer service!


#7

Ohh my gosh, that’s hilarious! I almost included a new USB cable too. :sweat_smile:

Well, glad to hear they are working!