Detection of TinyFPGA BX on ThinkPad X230 (Linux/Windows)


#1

Hello everybody out there using TinyFPGA,
I’m trying to use TinyFPGA for the first time.
I began by using the TinyFPGA on a ThinkPad X230 with Icestudio on Windows 10, which resulted in the error message “Board TinyFPGA BX not connected (Bootloader not active)”.
For easier debugging, I used another ThinkPad X230 running Ubuntu 18.04 and got the same error message with Icestudio.
I switched to the command line and used tinyprog -l which gives me an error message about /dev/ttyACM0 being in use while one of the LEDs on the FPGA is blinking. When the LED stops blinking there isn’t any active bootloader found.
When I run lsusb while the LED is blinking, there is a Bus 001 Device 008: ID 1209:2100 InterBiometrics message.
I had soldered pin headers to the FPGA and put a LED and a resistor between Pin 1 and Gnd of the TinyFPGA. The LED was on all the time.


#2

I don’t know about your Windows issue, but on Linux try disabling ModemManager - sudo systemctl stop ModemManager.service and sudo systemctl disable ModemManager.service


#3

Thanks a lot for your answer.
I will try to follow your instructions.
The problem on Windows (Microsoft) is not so important.