Lattice Demo Projects - it wont compile properly


#1

Hi All

Not sure here is the right to discuss my issues on Lattice FPGA(ECP5)
Recently, found a development kit in Lattice which I was looking for and cannot find a Intel(Altera) which I have been using for years.

I downloaded the design files in demo projects in lattice websites.
There are many compile issues from missing and not added properly source files.
(I might not be familiar with Lattice tools yet, but for sure …)

Asked Lattices, Not yet in a week. Not sure I could get answer from the technical support.
I am worrying to buy the development kit.
Is there anyone having same problems in lattice development kit and demo projects?
How to solve this issue , and where to contact? is there any user forum to share building projects?

vraifluss


#2

I think we need more information:

  1. What board are you using?
  2. What demo project are you trying to build?
  3. Exactly who’ve version of Lattice software are you using?
  4. Exactly what errors are you getting?

Be as specific as possible with screenshots and links to versions/files you have downloaded.


#3

I am using these and having an missing " image_fifo". I donot see any documents in google and alttice web site. Any advice?

What board are you using?
=> Embedded Vision Development Kit

What demo project are you trying to build?
=> ECP5_Raw10toParallel

Exactly who’ve version of Lattice software are you using?
=> Lattice Diamond Version(64bit) 3.10.0.111.2

Exactly what errors are you getting?
=> ECP5_Raw10toParallel\source\image_pipe.v":103:11:103:21|Reference to undefined module image_fifo