Serial device not mounting (Windows 10)


#1

Hi all,

I received my TinyFGPA BX a couple of weeks ago and finally got to hooking it up. I’m seeing a problem where the board isn’t registering as a COM device in Windows 10. I checked the other posts but couldn’t find a solution to my problem.

I’ve followed the setup steps from https://tinyfpga.com/bx/guide.html but when I get to running ‘apio drivers --serial-enable’, the following window pops up:
driver_installed

When I then run “apio system --lsserial” I get “Number of Serial devices found: 0”. Device manager shows the device as “Unknown USB Device (Device Descriptor Request Failed)”.

Has anyone else seen this before or even better does someone maybe have a solution? :slight_smile:

Kind regards
Tinus


#2

I haven’t seen this happen on Windows 10 before. Are you using a hub? Try using a different hub, port, and/or cable.

Is it an Intel or AMD machine?


#3

I’m connecting directly to the PC’s USB (no hub) and I’ve tried multiple ports and cables. It’s an Intel machine.

I do see something that doesn’t look right when checking libusb:
tinyprog -l --libusb
Traceback (most recent call last):
File “c:\users\admin\appdata\local\programs\python\python36\lib\runpy.py”, line 193, in run_module_as_main
main”, mod_spec)
File “c:\users\admin\appdata\local\programs\python\python36\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "C:\Users\Admin\AppData\Local\Programs\Python\Python36\Scripts\tinyprog.exe_main
.py", line 9, in
File "c:\users\admin\appdata\local\programs\python\python36\lib\site-packages\tinyprog_main
.py", line 249, in main
active_boards = get_ports(device) + get_ports(“1209:2100”)
File “c:\users\admin\appdata\local\programs\python\python36\lib\site-packages\tinyprog_init_.py”, line 39, in get_ports
for d in usb.core.find(idVendor=vid, idProduct=pid, find_all=True)
File “c:\users\admin\appdata\local\programs\python\python36\lib\site-packages\usb\core.py”, line 1263, in find
raise NoBackendError(‘No backend available’)
usb.core.NoBackendError: No backend available

Any ideas?


#4

I’m reading that the bootloader LED should be flashing but mine just remains on, not sure if this points to a possible problem?


#5

Do you have two lights on or just one?


#6

Both the PWR and BOOT LEDs are on, the BOOT one being slightly dimmer than the PWR one.


#7

Have you tried pressing the reset button on the board to get it back into the bootloader?


#8

Yes, I’ve tried but the LED just always stays on, so visually atleast it doesn’t look like anything happens when I press the button.


#9

Sounds like you got a bum board! No worries, I’ll take care it. :sweat_smile:


#10

Thank you @lukevalenty