Solved: Program TinyFpga Ax1 & AX2 w/ FT2232H-56Q MINI Module


#1

This is for those not familiar with programming the AX1 or AX2 using the FT2232H-56Q MINI Module

This particular mini module has two jumpers. JP1 to connect USB 5V+ to the FT2232H Chip and JP2 to connect 3.3V from the FT2232H chip to the FT2232H VIO pins. In my case this is the correct configuration. If you do not have jumpers you’ll need to do this with wiring.

The next thing to do is get the device driver… I have windows 10. In the control panel click on the Device Manager. Now plug the device into your computer usb port with a mini usb cable. A short time later, almost instant, the device manger will detect the device in an “Other Device or unknown” or like item drop down. Windows did not ask to automatically install on my computer. I double clicked the FT2232H… items and that started up the installation process. Follow the directions and let it find the driver and install it.

I followed the TinyFpga UserGuide instructions. But it did not program the TinyFpga. Lattice Diamond has to select one of two ports. The FT2232H device has two ports, port 0 and port 1. I wired up port 0 FT2232H JTAG pins. This needs to be selected first, a selection window popped up in the right hand side of Lattice Diamond. Select the port you wired up here.

It then programmed just fine. But the LEDs did not blink.

I modified the verilog code to get rid of the Lattice Diamond warnings and then it worked. I removed assign Z statements for the pins wired to the leds. I changed these pins from inout to output. I think this is what fixed the code.

I will add images shortly
I purchase themini module from digi-key


#2


#3